IM-440 - users may be unable to access dayforce, tuffshed.com, or 888tuffshed.com

Incident Report for Tuff Shed

Resolved

At this time all services are back to normal.
Posted Nov 18, 2025 - 08:49 MST

Update

We are getting reports that services using Cloudflare are returning to normal. We will continue to monitor.
Posted Nov 18, 2025 - 07:40 MST

Identified

We are aware of an issue with Cloudflare, a widely used web content delivery provider, that is causing problems accessing websites such as Dayforce, tuffshed.com and 888tuffshed.com. Some sites may fail to load showing a Cloudflare error, and some sites may load intermittently or based on geographic region. We will continue to work with Cloudflare and monitor the situation.
Posted Nov 18, 2025 - 07:27 MST
This incident affected: Websites (tuffshed.com, 888tuffshed.com / Service Connect), IT Support Tools (IT Support Portal), and Dayforce (HR System).