IM-320 Error while trying to checkout on 888tuffshed.com
Incident Report for Tuff Shed
Resolved
This incident is resolved. Please submit a ticket to IT Support if you have further issues.
Posted Mar 18, 2024 - 10:15 MDT
Monitoring
A fix has been implemented and we're monitoring the results. Please submit a ticket to IT Support if you continue to have issues.
Posted Mar 18, 2024 - 09:00 MDT
Investigating
Users are receiving a “Something Went Wrong” error while trying to checkout on 888tuffshed.com. We’re investigating this now.
Posted Mar 18, 2024 - 08:01 MDT
This incident affected: Websites (888tuffshed.com / Service Connect).