IM-317 - Concur is currently unavailable.
Incident Report for Tuff Shed
Resolved
Concur has indicated that the issue is resolved. Testing with users has confirmed that all services are functional, although some are slower than normal.
Posted Mar 04, 2024 - 12:58 MST
Monitoring
Some users are reporting that the concur is working again. We will continue to monitor.
Posted Mar 04, 2024 - 10:06 MST
Identified
We are aware of issues impacting Concur and are working with Concur to resolve the issue.
Posted Mar 04, 2024 - 07:36 MST
This incident affected: Concur.