IM-459 JDE Slow Performance

Incident Report for Tuff Shed

Resolved

We have implemented a fix that has addressed the performance issues with JDE. Thanks again for your patience while we work towards a resolution.
Posted Apr 21, 2026 - 10:21 MDT

Investigating

We are currently investigating the performance related issues in JDE.
Posted Apr 20, 2026 - 13:38 MDT
This incident affected: JD Edwards.