IM-347 Promo not showing on 888tuffshed.com/Service Connect
Incident Report for Tuff Shed
Resolved
This incident is resolved. The Home Depot promo will now show and apply correctly in the configurator. Please relaunch your quote for the change to take effect.
Posted Jul 25, 2024 - 09:00 MDT
Investigating
We’re investigating an issue where the current promo is not showing on 888tuffshed.com and Service Connect.
Posted Jul 25, 2024 - 07:27 MDT
This incident affected: Websites (888tuffshed.com / Service Connect) and KBMax (Product Configurator).