IM-445 Dialpad General Issues

Incident Report for Tuff Shed

Monitoring

Dialpad has indicated on its status page that the issues should now be resolved and we are monitoring. Thanks again for your patience.
Posted Mar 10, 2026 - 15:55 MDT

Investigating

Dialpad is currently reporting issues ranging from call related issues, slow load times and Salesforce CTI connectivity issues on their status page. More updates to come as we receive them from Dialpad.
Posted Mar 10, 2026 - 10:13 MDT
This incident affects: Salesforce (Salesforce CRM) and Dialpad (Phone System).