IM-456 Service Connect Payment Issue

Incident Report for Tuff Shed

Monitoring

A fix for the payment submission issue has been implemented and we are monitoring.
Posted Mar 18, 2026 - 14:42 MDT

Identified

The issue has been identified and we are working on a fix.
Posted Mar 18, 2026 - 12:41 MDT

Investigating

We are investigating the issue with team members not being able to submit payment on 888tuffshed.com.
Posted Mar 18, 2026 - 12:11 MDT
This incident affects: Websites (888tuffshed.com / Service Connect).