IM-439 Issues Entering Tuff Shed Leads In Service Connect

Incident Report for Tuff Shed

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 13:15 MST

Investigating

We are currently investigating an issue on HD Service Connect where people who are signing in as a HD associate are unable to enter a Tuff Shed lead. More details to come as we investigate.
Posted Nov 17, 2025 - 10:21 MST
This incident affected: Websites (888tuffshed.com / Service Connect).