IM-329 Expense and mileage options missing in Concur
Incident Report for Tuff Shed
Resolved
This incident is resolved. Let IT Support know if you have further issues.
Posted May 06, 2024 - 09:13 MDT
Update
Concur is continuing to investigate this issue. We will provide an update as soon as we know more.
Posted May 03, 2024 - 09:06 MDT
Investigating
We're receiving reports that expense and mileage options are missing in Concur. We've reached out to their team to investigate.
Posted May 02, 2024 - 14:09 MDT
This incident affected: Concur.