IM-433 Microsoft Azure is experiencing an outage

Incident Report for Tuff Shed

Update

Microsoft has confirmed Azure is down. This impacts multiple Tuff Shed applications such as the configurator and Conga Composer. Our team is continuing to monitor the situation and will update once we have more information.
Posted Oct 29, 2025 - 11:04 MDT

Investigating

We're investigating reports of the configurator not loading across all platforms.
Posted Oct 29, 2025 - 10:40 MDT
This incident affects: Salesforce (Document Services) and KBMax (Product Configurator).