IM-428 Salesforce/Dialpad Calls Not Logging

Incident Report for Tuff Shed

Update

We are continuing to investigate this issue and are working with Dialpad/Salesforce support. We will update you as more information arrives.
Posted Nov 17, 2025 - 07:30 MST

Update

We are continuing to investigate this issue and are working with Dialpad/Salesforce support. We will update you as more information arrives.
Posted Nov 14, 2025 - 10:07 MST

Investigating

We are currently investigating an issue where calls are not being logged in the Salesforce activity log. More updates to come.

You can still perform this action manually on Salesforce objects by clicking the "Log a Call" button.
Posted Nov 13, 2025 - 11:49 MST
This incident affects: Salesforce (Salesforce CRM) and Dialpad (Phone System).