IM-471 - Inaccurate Tableau Data

Incident Report for Tuff Shed

Resolved

We have investigated the incident surrounding the inaccurate Tableau data and have confirmed the data is accurate.
Posted Jul 07, 2026 - 11:14 MDT

Investigating

We are investigating reports that there are inaccuracies in Tableau data from 7/1 - 7/5. Thanks for your patience.
Posted Jul 07, 2026 - 07:19 MDT
This incident affected: Business Intelligence (Tableau).