IM-420: Configurator Delays

Incident Report for Tuff Shed

Resolved

This issue has been resolved. The Configurator is operating as expected.
Posted Jul 18, 2025 - 11:33 MDT

Monitoring

Document generation has continued to remain stable. We will continue to monitor the results and work with the vendor to identify the root cause of this issue.
Posted Jul 16, 2025 - 16:24 MDT

Identified

The vendor applied a fix. Users should begin to see performance improvement.
Posted Jul 16, 2025 - 10:42 MDT

Update

The Digital Team continues to investigate with the vendor to determine a root cause.
Posted Jul 16, 2025 - 10:02 MDT

Update

Users continue to see mixed results. The case has been escalated to the vendor.
Posted Jul 15, 2025 - 16:05 MDT

Update

Some users are experiencing improved performance with the configurator - Builder's Helper documents are generating, and other functionality may be restored. The Digital Team continues to investigate.
Posted Jul 15, 2025 - 13:02 MDT

Investigating

The Salesforce configurator is experiencing delayed response times resulting in blank shed configurations and data missing from Builder’s Helper documents. The Digital Team is investigating.
Posted Jul 15, 2025 - 11:03 MDT
This incident affected: Salesforce (Document Services) and KBMax (Product Configurator).