IM-226 Dayforce experiencing slow load times and page errors
Incident Report for Tuff Shed
Resolved
This incident has been resolved. Please reach out to IT support if you have further issues with Dayforce.
Posted Sep 26, 2022 - 14:04 MDT
Monitoring
Dayforce has implemented a fix and is reporting success with pages loading. We will continue to monitor the situation.
Posted Sep 26, 2022 - 12:19 MDT
Update
Dayforce is continuing to investigate this issue.
Posted Sep 26, 2022 - 10:38 MDT
Update
Dialpad's technical team is continuing to investigate this issue.
Posted Sep 26, 2022 - 09:45 MDT
Investigating
Users are reporting slow load times or errors while navigating within Dayforce. We've reached out to their technical team to investigate this.
Posted Sep 26, 2022 - 08:57 MDT
This incident affected: Dayforce (HR System).