Dialpad actively reported an affecting many users, who experienced difficulty making and receiving calls.
Root Cause Analysis
This was likely related to a wider Google outage.
Resolution
Vendor fix
Lessons Learned
N/A
Posted Jun 12, 2025 - 16:04 MDT
Resolved
The incident has been resolved. If you are experiencing difficulties with Dialpad, please contact Support.
Posted Jun 12, 2025 - 16:01 MDT
Monitoring
The vendor has released a fix, restoring service. Users, however, may still experience intermittent issues. The Digital Team will monitor and provide further updates.
Posted Jun 12, 2025 - 14:56 MDT
Identified
The vendor has identified the issue and is working to resolve it.
Posted Jun 12, 2025 - 13:06 MDT
Investigating
The vendor is reporting an active outage affecting Dialpad users, who may experience difficulty making and receiving calls. Dialpad is investigating the issue.