IM-328 Users unable to access Intellishift application
Incident Report for Tuff Shed
Resolved
This incident is resolved.
Posted May 03, 2024 - 08:52 MDT
Monitoring
Intellishift has implemented a fix and will continue to monitor the results.
Posted May 02, 2024 - 10:46 MDT
Investigating
We are aware of an issue impacting Intellishift login's and are working with the vendor to resolve the issue.
Posted Apr 29, 2024 - 15:28 MDT
This incident affected: Fleet Tracking.