IM-406 Error in Salesforce after clicking link in TSQ email

Incident Report for Tuff Shed

Resolved

We’ve implemented a fix and are seeing success with accessing these leads via email. Contact IT Support if you have further issues.
Posted May 09, 2025 - 11:27 MDT

Investigating

We've investigating an issue where users are clicking the link within their TSQ Notification Email and are receiving an error in Salesforce. The error indicates there was a problem and Salesforce can't find the the record.
Posted May 09, 2025 - 10:44 MDT
This incident affected: Salesforce (Salesforce Platform).