IM-325 Display sheds are not showing on 888tuffshed.com
Incident Report for Tuff Shed
Resolved
We've identified the issue and implemented a fix. We can confirm display sheds are now appearing correctly on 888tuffshed.com.
Posted Apr 16, 2024 - 14:22 MDT
Investigating
Display sheds are not appearing when searching via zip code on 888tuffshed.com. We're looking into this now.
Posted Apr 12, 2024 - 08:25 MDT
This incident affected: Websites (888tuffshed.com / Service Connect).