IM-326 Dialpad desk phones are not receiving phone calls
Incident Report for Tuff Shed
Resolved
This incident is resolved. Please contact IT Support if you have further issues.
Posted Apr 13, 2024 - 15:28 MDT
Monitoring
Dialpad has implemented a fix and will be monitoring the results. Please reach out to IT Support if you continue to have issues.
Posted Apr 13, 2024 - 13:17 MDT
Investigating
Dialpad desk phones are not receiving phone calls. Dialpad’s team is investigating the issue. In the meantime, users can still receive and make calls on mobile devices and computers.
Posted Apr 13, 2024 - 09:35 MDT
This incident affected: Dialpad (Phone System).