IM-477 Dialpad Login & Calling Issues

Incident Report for Tuff Shed

Resolved

The Dialpad outage should now be resolved. Thanks again for your patience.
Posted Sep 01, 2026 - 14:33 MDT

Monitoring

Dialpad has implemented a fix to address the outage and we are monitoring.
Posted Sep 01, 2026 - 13:30 MDT

Investigating

We are currently the reported Dialpad logging in and calling issues. Dialpad has declared a partial outage on their end. Thanks for your patience.
Posted Sep 01, 2026 - 11:42 MDT
This incident affected: Dialpad (Phone System).