IM-411 - June Retail Promo not applying discounting in configurator

Incident Report for Tuff Shed

Resolved

We have confirmed with several users in the field that the issue is resolved and the promo appearing correctly.
Posted Jun 02, 2025 - 11:56 MDT

Monitoring

We have identified the cause of the retail promo not applying and have implemented a fix. We will be monitoring for resolution.
Posted Jun 02, 2025 - 10:44 MDT

Investigating

We are investigating reports that the June retail promo for retail is not applying the correct discounting in the configurator.
Posted Jun 02, 2025 - 06:46 MDT
This incident affected: KBMax (Product Configurator).